summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/buildbot/worker.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-11-18 14:44:18 +0100
committertv <tv@krebsco.de>2016-11-18 14:44:18 +0100
commit151ca19a6e67e0c7644f489069cfbc17cec71187 (patch)
treef84467f88558afb721ca716cc582e6d0b9abadf3 /krebs/5pkgs/buildbot/worker.nix
parent0f523dfd8a560aa5f5e36c90d47e2322f3dd7882 (diff)
parent0155fc32e1b79bc25fdfc81ee8460438b70ba128 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'krebs/5pkgs/buildbot/worker.nix')
-rw-r--r--krebs/5pkgs/buildbot/worker.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/krebs/5pkgs/buildbot/worker.nix b/krebs/5pkgs/buildbot/worker.nix
new file mode 100644
index 00000000..c100de5d
--- /dev/null
+++ b/krebs/5pkgs/buildbot/worker.nix
@@ -0,0 +1,24 @@
+{ pkgs, stdenv, fetchurl, pythonPackages }:
+pythonPackages.buildPythonApplication (rec {
+ name = "${pname}-${version}";
+ pname = "buildbot-worker";
+ version = "0.9.1";
+
+ doCheck = false;
+ src = fetchurl {
+ url = "mirror://pypi/b/${pname}/${name}.tar.gz";
+ sha256 = "00p9l1qz6mx12npjwsycp8f9a8f2har15ig79pfsg8z7a7yw93hx";
+ };
+
+ buildInputs = with pythonPackages; [ setuptoolsTrial mock ];
+ propagatedBuildInputs = with pythonPackages; [ twisted future pkgs.treq ];
+
+ meta = with stdenv.lib; {
+ homepage = http://buildbot.net/;
+ description = "Buildbot Worker Daemon";
+ maintainers = with maintainers; [ nand0p ryansydnor ];
+ platforms = platforms.all;
+ license = licenses.gpl2;
+ };
+})
+