summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-08-13 17:09:56 +0200
committertv <tv@shackspace.de>2015-08-13 17:09:56 +0200
commita33f90358d0f57025daddb0ae41d65707fb34cf3 (patch)
tree7f91c889c45fd8995af98d91b0670fb0e90b1d53 /krebs/4lib/types.nix
parent9f92ba455c4b13f4d960bae65cd577c9aad30dc4 (diff)
parent4366ffd6c5d401e3719a588f5ac98365aef8bd89 (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 92410dd5..975c36b0 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -20,6 +20,7 @@ types // rec {
type = attrsOf net;
apply = x: assert hasAttr "retiolum" x; x;
};
+
secure = mkOption {
type = bool;
default = false;
@@ -73,6 +74,11 @@ types // rec {
}));
default = null;
};
+ zones = mkOption {
+ default = [];
+ # TODO: string is either MX, NS, A or AAAA
+ type = with types; listOf (attrsOf str);
+ };
};
});