summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-10-19 12:32:12 +0200
committermakefu <github@syntax-fehler.de>2016-10-19 12:32:12 +0200
commit0868101f2adc00f4e13a4ea242dc3bd23070917f (patch)
treea155571c2c448e51e5b1461228d7b46dda64a07f /krebs/4lib/types.nix
parentccd89b19f3fbbb6acb94be8f9f54d4e673ee33dc (diff)
parentce58a50de30fd49d4c000a81f9b7ce9baf0ccd66 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix14
1 files changed, 2 insertions, 12 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 37d44606..8d6ace2e 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -1,14 +1,9 @@
-{ config, lib, ... }:
+{ lib, ... }:
with builtins;
with lib;
with types;
-let
- # Inherited attributes are used in submodules that have their own `config`.
- inherit (config.krebs) build users;
-in
-
types // rec {
host = submodule ({ config, ... }: {
@@ -27,7 +22,6 @@ types // rec {
owner = mkOption {
type = user;
- default = users.krebs;
};
extraZones = mkOption {
@@ -49,10 +43,6 @@ types // rec {
ssh.pubkey = mkOption {
type = nullOr ssh-pubkey;
default = null;
- apply = x:
- optionalTrace (x == null && config.owner.name == build.user.name)
- "The option `krebs.hosts.${config.name}.ssh.pubkey' is unused."
- x;
};
ssh.privkey = mkOption {
type = nullOr ssh-privkey;
@@ -187,7 +177,6 @@ types // rec {
};
owner = mkOption {
type = user;
- default = users.root;
};
group-name = mkOption {
type = str;
@@ -284,6 +273,7 @@ types // rec {
};
mail = mkOption {
type = str; # TODO retiolum mail address
+ default = "${config._module.args.name}@${config.networking.hostName}.r";
};
name = mkOption {
type = username;