summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-28 21:00:27 +0100
committermakefu <github@syntax-fehler.de>2015-12-28 21:00:27 +0100
commit72d821d96cc7c19134773d6a07317bf7d6c2465c (patch)
tree8d30a69e6feb2a3de26591a87f1acdaba7f5a758 /krebs/4lib/types.nix
parent246116dabbe849e75612fbdb57b01696913ff27e (diff)
parent5a9ccbef0abe1f3acb16d716a2e1d7faa9bb0af1 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index c52afa24..81ce659b 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -177,4 +177,21 @@ types // rec {
addr6 = str;
hostname = str;
label = str;
+
+ krebs.file-location = types.submodule {
+ options = {
+ # TODO user
+ host = mkOption {
+ type = host;
+ };
+ # TODO merge with ssl.privkey.path
+ path = mkOption {
+ type = types.either types.path types.str;
+ apply = x: {
+ path = toString x;
+ string = x;
+ }.${typeOf x};
+ };
+ };
+ };
}