summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-27 19:41:01 +0200
committermakefu <github@syntax-fehler.de>2015-09-27 19:41:01 +0200
commitbc2bd6e2f6e9295b14e641b82bff62b40641988d (patch)
tree8bc4b655c12b4e0bc33051116a3adb3003463d34 /krebs/4lib/types.nix
parentc65614cdef66c38ff2939928e9072873e19e1c37 (diff)
parent170191034e51fb7e80ff6e6ddcac103ec7527afd (diff)
Merge branch 'before-merge'
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index f6b4bd8b..dbffdf85 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -27,6 +27,16 @@ types // rec {
type = with types; attrsOf string;
};
+ infest = {
+ addr = mkOption {
+ type = str;
+ };
+ port = mkOption {
+ type = int;
+ default = 22;
+ };
+ };
+
secure = mkOption {
type = bool;
default = false;