summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/shell.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-08-02 20:41:47 +0200
committerlassulus <lass@aidsballs.de>2016-08-02 20:41:47 +0200
commit2a263f14abf8baff0cc686b1dd11a349da87f067 (patch)
treecdc5a429dcaa92b8d5536642d58c4b1a2835e83d /krebs/4lib/shell.nix
parent127b8c0989f1dc71313af67fb5e69c709df019f3 (diff)
parent0928cc03a6191640c66c9122159994855527faef (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/4lib/shell.nix')
-rw-r--r--krebs/4lib/shell.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/krebs/4lib/shell.nix b/krebs/4lib/shell.nix
deleted file mode 100644
index 5910adac..00000000
--- a/krebs/4lib/shell.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ lib, ... }:
-
-with builtins;
-with lib;
-
-rec {
- escape =
- let
- isSafeChar = c: match "[-+./0-9:=A-Z_a-z]" c != null;
- in
- stringAsChars (c:
- if isSafeChar c then c
- else if c == "\n" then "'\n'"
- else "\\${c}");
-
- #
- # shell script generators
- #
-
- # example: "${cat (toJSON { foo = "bar"; })} | jq -r .foo"
- cat = s: "printf '%s' ${escape s}";
-}