summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/shell.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-03 09:28:59 +0200
committermakefu <github@syntax-fehler.de>2016-08-03 09:28:59 +0200
commitcba2979f860e3b55f82c58883bac84ceacd005bb (patch)
treeee421f8093206d76b61781e7777baa66816c412b /krebs/4lib/shell.nix
parentb68633c0272514dd4f2d235796f87021664730c2 (diff)
parent46d73a70ce2df4af2d66228874470cb4c8657f14 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/4lib/shell.nix')
-rw-r--r--krebs/4lib/shell.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/krebs/4lib/shell.nix b/krebs/4lib/shell.nix
deleted file mode 100644
index 5910adac..00000000
--- a/krebs/4lib/shell.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ lib, ... }:
-
-with builtins;
-with lib;
-
-rec {
- escape =
- let
- isSafeChar = c: match "[-+./0-9:=A-Z_a-z]" c != null;
- in
- stringAsChars (c:
- if isSafeChar c then c
- else if c == "\n" then "'\n'"
- else "\\${c}");
-
- #
- # shell script generators
- #
-
- # example: "${cat (toJSON { foo = "bar"; })} | jq -r .foo"
- cat = s: "printf '%s' ${escape s}";
-}