summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc_graphs.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-06-13 13:50:52 +0200
committerlassulus <lass@aidsballs.de>2016-06-13 13:50:52 +0200
commit23385c2984c9d4fbff65c920d9d59bc29314a639 (patch)
treed7e4f635be78922359b21970f6a6c8731995e38d /krebs/3modules/tinc_graphs.nix
parentde43b0e6f50e4d044cc0609a3d7d7c7d869552fe (diff)
parent2dd4dbbf6ea77972c7d5edb0ec25b8e778bfeb50 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/3modules/tinc_graphs.nix')
-rw-r--r--krebs/3modules/tinc_graphs.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/krebs/3modules/tinc_graphs.nix b/krebs/3modules/tinc_graphs.nix
index 2692de98..dec89d24 100644
--- a/krebs/3modules/tinc_graphs.nix
+++ b/krebs/3modules/tinc_graphs.nix
@@ -94,8 +94,7 @@ let
TimeoutSec = 300; # we will wait 5 minutes, kill otherwise
restart = "always";
- ExecStartPre = pkgs.writeScript "tinc_graphs-init" ''
- #!/bin/sh
+ ExecStartPre = pkgs.writeDash "tinc_graphs-init" ''
mkdir -p "${internal_dir}" "${external_dir}"
if ! test -e "${cfg.workingDir}/internal/index.html"; then
cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/internal/." "${internal_dir}"
@@ -106,8 +105,7 @@ let
'';
ExecStart = "${pkgs.tinc_graphs}/bin/all-the-graphs";
- ExecStartPost = pkgs.writeScript "tinc_graphs-post" ''
- #!/bin/sh
+ ExecStartPost = pkgs.writeDash "tinc_graphs-post" ''
# TODO: this may break if workingDir is set to something stupid
# this is needed because homedir is created with 700
chmod 755 "${cfg.workingDir}"