summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/rtorrent.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2020-06-02 23:35:17 +0200
committertv <tv@krebsco.de>2020-06-02 23:35:17 +0200
commit09c9f8f7fb04be39390b6f65966789c1bf6333e5 (patch)
treeb0cb0f718b40517b0645a38169e67b1088566f64 /krebs/3modules/rtorrent.nix
parent09e620c79b70e495e9651e8e5c1b160dd1b5fb8d (diff)
parent211e2ca6b9a1d8b4dd92071065b0b595123fe282 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/3modules/rtorrent.nix')
-rw-r--r--krebs/3modules/rtorrent.nix11
1 files changed, 2 insertions, 9 deletions
diff --git a/krebs/3modules/rtorrent.nix b/krebs/3modules/rtorrent.nix
index 43c2798d..eb27aa34 100644
--- a/krebs/3modules/rtorrent.nix
+++ b/krebs/3modules/rtorrent.nix
@@ -301,6 +301,7 @@ let
default = mkDefault true;
inherit (webcfg) basicAuth;
root = optionalString rucfg.enable webdir;
+ listen = [ { inherit (webcfg) addr port; } ];
locations = {
"/RPC2".extraConfig = ''
@@ -319,15 +320,7 @@ let
include ${pkgs.nginx}/conf/fastcgi.conf;
''; }
);
- # workaround because upstream nginx api changed
- # TODO remove when nobody uses 17.03 anymore
- } // (if hasAttr "port" (head options.services.nginx.virtualHosts.type.getSubModules).submodule.options then {
- port = webcfg.port;
- } else {
- listen = [
- { inherit (webcfg) addr port; }
- ];
- });
+ };
};
rutorrent-imp = {