summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/retiolum.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-11-11 13:44:55 +0100
committermakefu <github@syntax-fehler.de>2016-11-11 13:44:55 +0100
commit4d7f0e6c5bcd8b586711ad2394fac73ebbd3312d (patch)
treea21db730913e0915ec1e319af70673e7cf4e5001 /krebs/3modules/retiolum.nix
parent6c092cd20ca256b1cefa92aa779380cdb71c1313 (diff)
parent0e13a4e2373d891e6a895e4b6ad2b42da028ba12 (diff)
Merge remote-tracking branch 'prism/lassulus'
Diffstat (limited to 'krebs/3modules/retiolum.nix')
-rw-r--r--krebs/3modules/retiolum.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/krebs/3modules/retiolum.nix b/krebs/3modules/retiolum.nix
index fddaed9e..0a3d7ed2 100644
--- a/krebs/3modules/retiolum.nix
+++ b/krebs/3modules/retiolum.nix
@@ -79,6 +79,15 @@ let
'';
};
+ hostsArchive = mkOption {
+ type = types.package;
+ default = pkgs.runCommand "retiolum-hosts.tar.bz2" {} ''
+ ${pkgs.coreutils}/bin/ln -s ${tinc.config.hostsPackage} hosts
+ ${pkgs.gnutar}/bin/tar -hcjf $out hosts
+ '';
+ readOnly = true;
+ };
+
hostsPackage = mkOption {
type = types.package;
default = pkgs.stdenv.mkDerivation {
@@ -125,7 +134,11 @@ let
connectTo = mkOption {
type = types.listOf types.str;
- default = [ "fastpoke" "cd" "prism" "gum" ];
+ ${if tinc.config.netname == "retiolum" then "default" else null} = [
+ "gum"
+ "ni"
+ "prism"
+ ];
description = ''
The list of hosts in the network which the client will try to connect
to. These hosts should have an 'Address' configured which points to a