summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/repo-sync.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-10-13 20:33:45 +0200
committertv <tv@krebsco.de>2016-10-13 20:33:45 +0200
commit65165f422d8e08f29ec269a3ce98e7ebfa22c622 (patch)
tree13d15f63626129c439840a4b406e3fe4e693096f /krebs/3modules/repo-sync.nix
parent38d26c551cf3c53151120646a893a13990b21c5c (diff)
parent8458ffd7a00a3e4c734755de7d72f95458d1bb52 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/3modules/repo-sync.nix')
-rw-r--r--krebs/3modules/repo-sync.nix40
1 files changed, 34 insertions, 6 deletions
diff --git a/krebs/3modules/repo-sync.nix b/krebs/3modules/repo-sync.nix
index 0317d1ec..bcd9da5e 100644
--- a/krebs/3modules/repo-sync.nix
+++ b/krebs/3modules/repo-sync.nix
@@ -17,29 +17,57 @@ let
# see `repo-sync --help`
# `ref` provides sane defaults and can be omitted
+ # you can have multiple repo-sync groups and therefore multiple @latest
+ # configuration entries.
# attrset will be converted to json and be used as config
- { repo = {
+ # each attrset defines a group of repos for syncing
+
+ { nxpkgs = {
makefu = {
origin = {
- url = http://github.com/makefu/repo ;
+ url = http://github.com/makefu/nixpkgs;
ref = "heads/dev" ;
};
mirror = {
- url = "git@internal:mirror" ;
+ url = "git@internal:nixpkgs-mirror" ;
ref = "heads/github-mirror-dev" ;
};
};
lass = {
origin = {
- url = http://github.com/lass/repo ;
+ url = http://github.com/lass/nixpkgs;
+ };
+ mirror = {
+ url = "git@internal:nixpkgs-mirror" ;
+ };
+ };
+ "@latest" = {
+ mirror = {
+ url = "git@internal:nixpkgs-mirror";
+ ref = "heads/master";
+ };
+ };
+ };
+ stockholm = {
+ lass = {
+ origin = {
+ url = http://cgit.prism.r/stockholm;
+ };
+ mirror = {
+ url = "git@internal:stockholm-mirror" ;
+ };
+ };
+ makefu = {
+ origin = {
+ url = http://gum.krebsco.de/stockholm;
};
mirror = {
- url = "git@internal:mirror" ;
+ url = "git@internal:stockholm-mirror" ;
};
};
"@latest" = {
mirror = {
- url = "git@internal:mirror";
+ url = "git@internal:stockholm-mirror";
ref = "heads/master";
};
};