summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-19 16:38:07 +0200
committermakefu <github@syntax-fehler.de>2017-09-19 16:38:07 +0200
commitcfca733473620e1b7be7e62a96f20958fedf9068 (patch)
tree4d69217c6c292e6524c05ce0ffa36ac209c6cad9 /krebs/3modules/git.nix
parent21c284a2c7b4fcb330f0c90ccd773f65f78721aa (diff)
parente822f88199f11fe75e2a38a0e5f9806a8c9ba5cf (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 93211d9d..610c20bb 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -186,6 +186,17 @@ let
};
repo = types.submodule ({ config, ... }: {
options = {
+ admins = mkOption {
+ type = types.listOf types.user;
+ default = [];
+ description = ''
+ List of users that should be able to do everything with this repo.
+
+ This option is currently not used by krebs.git but instead can be
+ used to create rules. See e.g. <stockholm/lass/2configs/git.nix> for
+ an example.
+ '';
+ };
cgit = {
desc = mkOption {
type = types.nullOr types.str;