summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/build.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-11 21:31:15 +0100
committermakefu <github@syntax-fehler.de>2016-02-11 21:31:15 +0100
commit014cbb7598c5d45cfc4cc7e1ec81c92e000eabfb (patch)
treefab0e894948010cd73be18ad2c68cd4750bd2419 /krebs/3modules/build.nix
parent8ecdb889dd3081ba29c6ea7eb35f60b30420d201 (diff)
parent7b3b839cc7a2af73dee9858e6ebcc7be831eb481 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/3modules/build.nix')
-rw-r--r--krebs/3modules/build.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/krebs/3modules/build.nix b/krebs/3modules/build.nix
index 00142acd..3530fd59 100644
--- a/krebs/3modules/build.nix
+++ b/krebs/3modules/build.nix
@@ -3,8 +3,6 @@
with lib;
let
- target = config.krebs.build // { user.name = "root"; };
-
out = {
# TODO deprecate krebs.build.host
options.krebs.build.host = mkOption {
@@ -17,12 +15,6 @@ let
default = "/nix/var/nix/profiles/system";
};
- # TODO make krebs.build.target.host :: host
- options.krebs.build.target = mkOption {
- type = with types; nullOr str;
- default = null;
- };
-
# TODO deprecate krebs.build.user
options.krebs.build.user = mkOption {
type = types.user;
@@ -74,7 +66,7 @@ let
unset tmpdir
trap '
- rm "$tmpdir"/*
+ rm -f "$tmpdir"/*
rmdir "$tmpdir"
trap - EXIT INT QUIT
' EXIT INT QUIT