summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/build.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-11-06 22:38:44 +0100
committermakefu <github@syntax-fehler.de>2015-11-06 22:38:44 +0100
commit9a0e67cf65c5a827df7fca7573f47f3a43474df6 (patch)
tree72058c48138b25e5a0397d21d27ea4cb2a6cca2e /krebs/3modules/build.nix
parent736e1426d5a7ec76d0987840552d56c6b4f0248e (diff)
parent4d93a8215f08cbea0bbcb8c668f2bbc9600016da (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/3modules/build.nix')
-rw-r--r--krebs/3modules/build.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/krebs/3modules/build.nix b/krebs/3modules/build.nix
index 1205e192..7f004cd8 100644
--- a/krebs/3modules/build.nix
+++ b/krebs/3modules/build.nix
@@ -29,10 +29,13 @@ let
};
options.krebs.build.source.dir = mkOption {
- type = types.attrsOf (types.submodule ({ config, ... }: {
+ type = let
+ default-host = config.krebs.current.host;
+ in types.attrsOf (types.submodule ({ config, ... }: {
options = {
host = mkOption {
type = types.host;
+ default = default-host;
};
path = mkOption {
type = types.str;