summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/brockman.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-06-10 15:29:55 +0200
committerlassulus <git@lassul.us>2023-06-11 16:50:45 +0200
commitb21dd1063f06d176913d064b5864092ffe0e5b17 (patch)
treee3801b629d2969f0581d07604672e8c4d92ade3a /krebs/3modules/brockman.nix
parentc94ebb5f5cba9b750cd132d3c354bd300e5fd433 (diff)
ci fixup
Diffstat (limited to 'krebs/3modules/brockman.nix')
-rw-r--r--krebs/3modules/brockman.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/krebs/3modules/brockman.nix b/krebs/3modules/brockman.nix
index e010800e..653ed355 100644
--- a/krebs/3modules/brockman.nix
+++ b/krebs/3modules/brockman.nix
@@ -1,6 +1,7 @@
{ pkgs, config, lib, ... }:
with lib;
let
+ slib = import ../../lib/lib.nix { inherit lib; };
cfg = config.krebs.brockman;
in {
options.krebs.brockman = {
@@ -14,7 +15,7 @@ in {
group = "brockman";
createHome = true;
isSystemUser = true;
- uid = genid_uint31 "brockman";
+ uid = slib.genid_uint31 "brockman";
};
users.groups.brockman = {};