summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/reaktor-krebs.nix
diff options
context:
space:
mode:
authornin <nineinchnade@gmail.com>2017-10-17 19:54:15 +0200
committernin <nineinchnade@gmail.com>2017-10-17 19:54:15 +0200
commit9afe5210f2a44cacac4f3527b6c8b561d9e4296b (patch)
treea83c412966783b123cd3152fe34a6f7cddcb55d6 /krebs/2configs/reaktor-krebs.nix
parentf4bf9110727f2c7113c80aaa88427b81605016ae (diff)
parent4667bb8e4111abde822ae57993a29929c5cc9aad (diff)
Merge remote-tracking branch 'temp/master'
Diffstat (limited to 'krebs/2configs/reaktor-krebs.nix')
-rw-r--r--krebs/2configs/reaktor-krebs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/2configs/reaktor-krebs.nix b/krebs/2configs/reaktor-krebs.nix
new file mode 100644
index 00000000..6b17b457
--- /dev/null
+++ b/krebs/2configs/reaktor-krebs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ krebs.Reaktor.krebs = {
+ nickname = "Reaktor|krebs";
+ channels = [
+ "#krebs"
+ "#nixos-wiki"
+ ];
+ extraEnviron = {
+ REAKTOR_HOST = "irc.freenode.org";
+ };
+ plugins = with pkgs.ReaktorPlugins; [
+ sed-plugin
+ wiki-todo-add
+ wiki-todo-done
+ wiki-todo-show
+ ];
+ };
+ services.nginx.virtualHosts."lassul.us".locations."/wiki-todo".extraConfig = ''
+ default_type "text/plain";
+ alias /var/lib/Reaktor/state/wiki-todo;
+ '';
+}