summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/mastodon.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2022-12-07 19:51:04 +0100
committertv <tv@krebsco.de>2022-12-07 19:51:04 +0100
commit9bcce729ef7de715cfcd61dfe1146d126878d48f (patch)
treeeab042a912a41b13ceb58b79f4de167779a427f1 /krebs/2configs/mastodon.nix
parent9a9b8e56eb6234650a369bbd24d41b8f4c66c78d (diff)
parent2eb33e60b45c2b37d51a57b0fbe4a023861a7429 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'krebs/2configs/mastodon.nix')
-rw-r--r--krebs/2configs/mastodon.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/krebs/2configs/mastodon.nix b/krebs/2configs/mastodon.nix
index d0c1943c..145b383e 100644
--- a/krebs/2configs/mastodon.nix
+++ b/krebs/2configs/mastodon.nix
@@ -15,7 +15,7 @@
configureNginx = true;
trustedProxy = config.krebs.hosts.prism.nets.retiolum.ip6.addr;
smtp.createLocally = false;
- smtp.fromAddress = "mastodon@social.krebsco.de";
+ smtp.fromAddress = "derp";
};
services.nginx.virtualHosts.${config.services.mastodon.localDomain} = {
@@ -36,5 +36,11 @@
(pkgs.writers.writeDashBin "tootctl" ''
sudo -u mastodon /etc/profiles/per-user/mastodon/bin/mastodon-env /etc/profiles/per-user/mastodon/bin/tootctl "$@"
'')
+ (pkgs.writers.writeDashBin "create-mastodon-user" ''
+ set -efu
+ nick=$1
+ /run/current-system/sw/bin/tootctl accounts create "$nick" --email "$nick"@krebsco.de --confirmed
+ /run/current-system/sw/bin/tootctl accounts approve "$nick"
+ '')
];
}