summaryrefslogtreecommitdiffstats
path: root/krebs/1systems/onebutton/config.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-06-28 00:12:11 +0200
committerlassulus <lass@blue.r>2018-06-28 00:12:11 +0200
commit370c2b511e1293e6112814c88ab8b93cac14ae2a (patch)
tree207dbd0f0d84809a56d676fcb15ff6f8205a643d /krebs/1systems/onebutton/config.nix
parentdac47a8abdedda4863b56cb83941e9e16929669b (diff)
parent4d07a747298fca730ba42f29e3f054be390dbab6 (diff)
Merge remote-tracking branch 'prism/makefu'
Diffstat (limited to 'krebs/1systems/onebutton/config.nix')
-rw-r--r--krebs/1systems/onebutton/config.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/krebs/1systems/onebutton/config.nix b/krebs/1systems/onebutton/config.nix
index dca00a20..b87aef5a 100644
--- a/krebs/1systems/onebutton/config.nix
+++ b/krebs/1systems/onebutton/config.nix
@@ -16,6 +16,36 @@
services.nixosManual.enable = false;
services.journald.extraConfig = "SystemMaxUse=50M";
}
+ {
+ systemd.services.mpc-booter = let
+ mpc = "${pkgs.mpc_cli}/bin/mpc -h mpd.shack -p 6600";
+ url = "http://lassul.us:8000/radio.ogg";
+ say = pkgs.writeDash "say" ''
+ tmpfile=$(${pkgs.coreutils}/bin/mktemp)
+ echo "$@" > $tmpfile
+ ${pkgs.curl}/bin/curl -i -H "content-type: text/plain" -X POST -d "@$tmpfile" gobbelz.shack/say/
+ rm "$tmpfile"
+ '';
+ in {
+ wantedBy = [ "multi-user.target" ];
+ after = [ "network-online.target" ];
+ serviceConfig = {
+ RemainAfterExit = "yes";
+ Type = "oneshot";
+ ExecStart = pkgs.writeDash "mpc-boot" ''
+ until ${mpc} stats;do
+ echo "waiting for mpd.shack to appear"
+ sleep 1
+ done
+ ${say} "Willkommen im Shack wertes Mitglied"
+
+ ${say} "Lassulus Super Radio wurde gestartet"
+ ${mpc} add ${url}
+ ${mpc} play
+ '';
+ };
+ };
+ }
];
krebs.build.host = config.krebs.hosts.onebutton;
# NixOS wants to enable GRUB by default