summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/emacs.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-26 21:06:17 +0200
committermakefu <github@syntax-fehler.de>2018-04-26 21:06:17 +0200
commit87b1aa3cdd796238ecbf61d3fcd5fcc08563aa82 (patch)
treeedf59f73bd0c61beb1a5e19f3661310031e7c5f5 /jeschli/2configs/emacs.nix
parent309124175425cb7abd6dad166f485ae832435562 (diff)
parent0b9727b3ad324b1d1f6a8db4181be546eb5ec397 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'jeschli/2configs/emacs.nix')
-rw-r--r--jeschli/2configs/emacs.nix27
1 files changed, 12 insertions, 15 deletions
diff --git a/jeschli/2configs/emacs.nix b/jeschli/2configs/emacs.nix
index d9e6c854..4c52432d 100644
--- a/jeschli/2configs/emacs.nix
+++ b/jeschli/2configs/emacs.nix
@@ -31,6 +31,7 @@ let
(scroll-bar-mode -1) ; Disable scroll bar
(setq inhibit-startup-screen t) ; Disable startup screen with graphics
(setq-default indent-tabs-mode nil) ; Use spaces instead of tabs
+ (setq default-tab-width 2) ; Two spaces is a tab
(setq tab-width 2) ; Four spaces is a tab
(setq visible-bell nil) ; Disable annoying visual bell graphic
(setq ring-bell-function 'ignore) ; Disable super annoying audio bell
@@ -45,30 +46,26 @@ let
(setq org-agenda-files (quote ("~/projects/notes")))
)
'';
- emacsFile = ''
+ recentFiles = ''
+ (recentf-mode 1)
+ (setq recentf-max-menu-items 25)
+ (global-set-key "\C-x\ \C-r" 'recentf-open-files)
+ '';
+ dotEmacs = pkgs.writeText "dot-emacs" ''
${packageRepos}
+ ${orgMode}
+ ${recentFiles}
${windowCosmetics}
- (custom-set-variables
- ;; custom-set-variables was added by Custom.
- ;; If you edit it by hand, you could mess it up, so be careful.
- ;; Your init file should contain only one such instance.
- ;; If there is more than one, they won't work right.
- '(inhibit-startup-screen t)
- '(org-agenda-files nil)
- '(package-selected-packages
- (quote
- (smex ox-jira org-plus-contrib org-mime org-jira neotree molokai-theme let-alist helm-fuzzy-find go-guru go-autocomplete flymake-go exec-path-from-shell evil-org cl-lib-highlight bbdb atom-one-dark-theme))))
- ${orgMode}
'';
- dotEmacs = pkgs.writeText "dot-emacs" emacsFile;
- emacs = (pkgs.emacsPackagesNgGen pkgs.emacs).emacsWithPackages (epkgs: [
+ emacsWithCustomPackages = (pkgs.emacsPackagesNgGen pkgs.emacs).emacsWithPackages (epkgs: [
epkgs.melpaStablePackages.magit
epkgs.melpaPackages.mmm-mode
epkgs.melpaPackages.nix-mode
epkgs.melpaPackages.go-mode
+ epkgs.melpaPackages.google-this
]);
myEmacs = pkgs.writeDashBin "my-emacs" ''
- exec ${emacs}/bin/emacs -q -l ${dotEmacs} "$@"
+ exec ${emacsWithCustomPackages}/bin/emacs -q -l ${dotEmacs} "$@"
'';
in {
environment.systemPackages = [