summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-12-12 18:24:01 +0100
committerlassulus <lassulus@lassul.us>2017-12-12 18:24:01 +0100
commit3a235667ca84cc91974b4aef906e0f9efe900893 (patch)
tree3682258b72d9844121a6013b7953f91a220a733b /jeschli/2configs/default.nix
parent8bad968312cbf384444aabcc333b802ec141b09e (diff)
parent79d41e9f54cecd7cc0098a55a8d4b758041369e1 (diff)
Merge remote-tracking branch 'prism/staging/jeschli'
Diffstat (limited to 'jeschli/2configs/default.nix')
-rw-r--r--jeschli/2configs/default.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/jeschli/2configs/default.nix b/jeschli/2configs/default.nix
new file mode 100644
index 00000000..7fb24095
--- /dev/null
+++ b/jeschli/2configs/default.nix
@@ -0,0 +1,66 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+{
+ imports = [
+ ./vim.nix
+ ./retiolum.nix
+ {
+ environment.variables = {
+ NIX_PATH = mkForce "secrets=/var/src/stockholm/null:/var/src";
+ };
+ }
+ ];
+
+ nixpkgs.config.allowUnfree = true;
+
+ environment.systemPackages = with pkgs; [
+ #stockholm
+ git
+ gnumake
+ jq
+ parallel
+ proot
+ populate
+
+ #style
+ most
+ rxvt_unicode.terminfo
+
+ #monitoring tools
+ htop
+ iotop
+
+ #network
+ iptables
+ iftop
+
+ #stuff for dl
+ aria2
+
+ #neat utils
+ file
+ kpaste
+ krebspaste
+ mosh
+ pciutils
+ psmisc
+ # q
+ # rs
+ tmux
+ untilport
+ usbutils
+ # logify
+ goify
+
+ #unpack stuff
+ p7zip
+ unzip
+ unrar
+
+ (pkgs.writeDashBin "sshn" ''
+ ${pkgs.openssh}/bin/ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no "$@"
+ '')
+ ];
+
+ krebs.enable = true;
+}