summaryrefslogtreecommitdiffstats
path: root/Zpkgs/krebs/hashPassword.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-28 21:38:22 +0200
committertv <tv@shackspace.de>2015-07-28 21:38:22 +0200
commit06cb4d25ef40773e2cc516e50a9aeec6cbe1d0a8 (patch)
treee05d849f048473aa9c90dc81b09d3a30dbe28ccc /Zpkgs/krebs/hashPassword.nix
parent060087fab989a2cf362928c471ac8fd9c4d95c1e (diff)
*/krebs -> krebs/*
Diffstat (limited to 'Zpkgs/krebs/hashPassword.nix')
-rw-r--r--Zpkgs/krebs/hashPassword.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/Zpkgs/krebs/hashPassword.nix b/Zpkgs/krebs/hashPassword.nix
deleted file mode 100644
index a10340cc..00000000
--- a/Zpkgs/krebs/hashPassword.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-{ lib, pkgs, ... }:
-
-pkgs.writeScriptBin "hashPassword" ''
- #! /bin/sh
- # usage: hashPassword
- set -euf
-
- export PATH=${lib.makeSearchPath "bin" (with pkgs; [
- coreutils
- mkpasswd
- openssl
- ])}
-
- salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
- exec mkpasswd -m sha-512 -S "$salt"
-''