summaryrefslogtreecommitdiffstats
path: root/4lib/tv/modules.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:49 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:49 +0200
commitbd65d2be622369d4f4b55a1d5e64aedf58506189 (patch)
tree22ddca93839a9cb9efb03fcc807dc12b1b9ea8a8 /4lib/tv/modules.nix
parent2bc5c58d85990e483af8fde57ed5f2442351b69c (diff)
parentd213df5c00d3073d2f3bc09471fce466153df881 (diff)
Merge branch 'next'
Diffstat (limited to '4lib/tv/modules.nix')
-rw-r--r--4lib/tv/modules.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/4lib/tv/modules.nix b/4lib/tv/modules.nix
new file mode 100644
index 00000000..248e638e
--- /dev/null
+++ b/4lib/tv/modules.nix
@@ -0,0 +1,21 @@
+let
+ pkgs = import <nixpkgs> {};
+ inherit (pkgs.lib) concatMap hasAttr;
+in rec {
+
+ no-touch-args = {
+ config = throw "no-touch-args: can't touch config!";
+ lib = throw "no-touch-args: can't touch lib!";
+ pkgs = throw "no-touch-args: can't touch pkgs!";
+ };
+
+ # list-imports : path -> [path]
+ # Return a module's transitive list of imports.
+ # XXX duplicates won't get eliminated from the result.
+ list-imports = path:
+ let module = import path no-touch-args;
+ imports = if hasAttr "imports" module
+ then concatMap list-imports module.imports
+ else [];
+ in [path] ++ imports;
+}