summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/tree.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-26 21:04:13 +0200
committertv <tv@shackspace.de>2015-07-26 21:13:50 +0200
commit98bc5991db76171ae9e1631b66f41061420624db (patch)
tree6ed126f57257c467d9a7414512c83e891bcd626c /4lib/krebs/tree.nix
parent4926abb00f74614e7748b8959b8d2fcd8e98dacc (diff)
3 krebs: make dns.providers part of api
Diffstat (limited to '4lib/krebs/tree.nix')
-rw-r--r--4lib/krebs/tree.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/4lib/krebs/tree.nix b/4lib/krebs/tree.nix
new file mode 100644
index 00000000..1cd83b3f
--- /dev/null
+++ b/4lib/krebs/tree.nix
@@ -0,0 +1,13 @@
+{ lib, ... }:
+
+with lib;
+
+rec {
+ # tree k v = set k (either v (tree k v))
+
+ # get : [k] -> tree k v -> v
+ get = path: tree:
+ if length path > 0
+ then get (tail path) tree.${head path} # TODO check if elem exists
+ else tree;
+}