summaryrefslogtreecommitdiffstats
path: root/3modules/tv/urlwatch.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-13 17:36:31 +0200
committertv <tv@shackspace.de>2015-07-13 17:47:49 +0200
commit0345c30b1b3c3b01ba5455a7fc6bee338c36052a (patch)
tree73cd25f1107480295823ca5f904362f98401e85a /3modules/tv/urlwatch.nix
parentc27bd8af5d8b0ef638d703ad8942ce2309785e2e (diff)
3 tv.*: use mkEnableOption
Diffstat (limited to '3modules/tv/urlwatch.nix')
-rw-r--r--3modules/tv/urlwatch.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/3modules/tv/urlwatch.nix b/3modules/tv/urlwatch.nix
index d6e796ca..aed24785 100644
--- a/3modules/tv/urlwatch.nix
+++ b/3modules/tv/urlwatch.nix
@@ -7,11 +7,12 @@
with builtins;
with lib;
-
let
cfg = config.tv.urlwatch;
api = {
+ enable = mkEnableOption "tv.urlwatch";
+
dataDir = mkOption {
type = types.str;
default = "/var/lib/urlwatch";
@@ -19,15 +20,6 @@ let
Directory where the urlwatch service should store its state.
'';
};
- enable = mkOption {
- type = types.bool;
- default = false;
- description = ''
- Whether to enable the urlwatch service.
- If enabled, then create a timer that calls urlwatch and sends mails
- whenever something has changed or an error occurs.
- '';
- };
from = mkOption {
type = types.str;
default = "${cfg.user}@${config.networking.hostName}.retiolum";