summaryrefslogtreecommitdiffstats
path: root/3modules/tv/identity.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-13 17:36:31 +0200
committertv <tv@shackspace.de>2015-07-13 17:47:49 +0200
commit0345c30b1b3c3b01ba5455a7fc6bee338c36052a (patch)
tree73cd25f1107480295823ca5f904362f98401e85a /3modules/tv/identity.nix
parentc27bd8af5d8b0ef638d703ad8942ce2309785e2e (diff)
3 tv.*: use mkEnableOption
Diffstat (limited to '3modules/tv/identity.nix')
-rw-r--r--3modules/tv/identity.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/3modules/tv/identity.nix b/3modules/tv/identity.nix
index 7cf90de0..c3c2f17b 100644
--- a/3modules/tv/identity.nix
+++ b/3modules/tv/identity.nix
@@ -1,9 +1,7 @@
{ lib, ... }:
with lib;
-
let
-
cfg = config.tv.identity;
out = {
@@ -12,10 +10,8 @@ let
};
api = {
- enable = mkOption {
- type = types.bool;
- default = false;
- };
+ enable = mkEnableOption "tv.identity";
+
self = mkOption {
type = types.unspecified;
};