summaryrefslogtreecommitdiffstats
path: root/3modules/krebs/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-24 20:48:00 +0200
committertv <tv@shackspace.de>2015-07-24 20:49:46 +0200
commita62be1cef8726a2afa61df3dac9e19a71882b370 (patch)
tree9415cfbe7628cbcce03d1691ea02e71be7babc88 /3modules/krebs/default.nix
parent54becaa19fcbc11ac709ddaf86e56ee3b736931d (diff)
{2 tv git -> 3 krebs}.users
Diffstat (limited to '3modules/krebs/default.nix')
-rw-r--r--3modules/krebs/default.nix54
1 files changed, 43 insertions, 11 deletions
diff --git a/3modules/krebs/default.nix b/3modules/krebs/default.nix
index fe94e09b..b8722d18 100644
--- a/3modules/krebs/default.nix
+++ b/3modules/krebs/default.nix
@@ -1,11 +1,43 @@
-_:
-
-{
- imports = [
- ./github-hosts-sync.nix
- ./git.nix
- ./nginx.nix
- ./retiolum.nix
- ./urlwatch.nix
- ];
-}
+{ config, lib, ... }:
+
+with import ../../4lib/krebs { inherit lib; };
+let
+ cfg = config.krebs;
+
+ out = {
+ imports = [
+ ./github-hosts-sync.nix
+ ./git.nix
+ ./nginx.nix
+ ./retiolum.nix
+ ./urlwatch.nix
+ ];
+ options.krebs = api;
+ config = mkIf cfg.enable imp;
+ };
+
+ api = {
+ users = mkOption {
+ type = with types; attrsOf user;
+ default = addNames {
+ lass = {
+ pubkey = readFile ../../Zpubkeys/lass.ssh.pub;
+ };
+ makefu = {
+ pubkey = readFile ../../Zpubkeys/makefu.ssh.pub;
+ };
+ tv = {
+ pubkey = readFile ../../Zpubkeys/tv_wu.ssh.pub;
+ };
+ uriel = {
+ pubkey = readFile ../../Zpubkeys/uriel.ssh.pub;
+ };
+ };
+ };
+ };
+
+ imp = {
+ };
+
+in
+out