summaryrefslogtreecommitdiffstats
path: root/2configs/lass/steam.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-16 15:51:01 +0200
committerlassulus <lass@aidsballs.de>2015-07-16 15:51:01 +0200
commitc3e295b56eba690fc5422b74a74ffca6d9f98ac5 (patch)
tree364dbf9606d2805fcd03e8814910db7e06f12450 /2configs/lass/steam.nix
parent670cfaf39aaacb87d49d3fdffa53df34ee0f4d95 (diff)
2 lass: re-add all configs
Diffstat (limited to '2configs/lass/steam.nix')
-rw-r--r--2configs/lass/steam.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/2configs/lass/steam.nix b/2configs/lass/steam.nix
new file mode 100644
index 00000000..d54873b1
--- /dev/null
+++ b/2configs/lass/steam.nix
@@ -0,0 +1,29 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}