summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-11 22:47:42 +0200
committermakefu <github@syntax-fehler.de>2018-09-11 22:47:42 +0200
commit969d4e1f6ad9e475d9416e22e52baa63c75c7d89 (patch)
tree860dd87d15137253dff6d4b2f7d1cefe5ae277fd /lib/default.nix
parent60bda6019f62fc8a94fd035c709e3efb2204c227 (diff)
optional string brackets
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 49c9daa..5209356 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -94,9 +94,9 @@ let {
# attrValues returns values sorted by name. This is important, because it
# ensures that "/" is processed before "/foo" etc.
in ''
- ${optionalString (hasAttr "luks" z) concatStringsSep "\n" (attrValues z.luks)}
- ${optionalString (hasAttr "lvm" z) concatStringsSep "\n" (attrValues z.lvm)}
- ${optionalString (hasAttr "luks" fs) concatStringsSep "\n" (attrValues z.fs)}
+ ${optionalString (hasAttr "luks" z) (concatStringsSep "\n" (attrValues z.luks))}
+ ${optionalString (hasAttr "lvm" z) (concatStringsSep "\n" (attrValues z.lvm))}
+ ${optionalString (hasAttr "luks" z) (concatStringsSep "\n" (attrValues z.fs))}
'';
mount.luks = q: x: (