summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/simple')
-rw-r--r--tv/5pkgs/simple/diff-so-fancy.nix6
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix9
-rw-r--r--tv/5pkgs/simple/hc.nix6
-rw-r--r--tv/5pkgs/simple/rox-filer.nix5
-rw-r--r--tv/5pkgs/simple/utsushi.nix40
5 files changed, 38 insertions, 28 deletions
diff --git a/tv/5pkgs/simple/diff-so-fancy.nix b/tv/5pkgs/simple/diff-so-fancy.nix
index 9ce6d923..d57e6e75 100644
--- a/tv/5pkgs/simple/diff-so-fancy.nix
+++ b/tv/5pkgs/simple/diff-so-fancy.nix
@@ -1,4 +1,6 @@
-{stdenv, git, perl, ncurses, coreutils, fetchFromGitHub, makeWrapper, ...}:
+{ fetchFromGitHub, lib, stdenv
+, coreutils, git, makeWrapper, ncurses, perl
+}:
stdenv.mkDerivation rec {
name = "diff-so-fancy-${version}";
@@ -34,7 +36,7 @@ stdenv.mkDerivation rec {
--prefix PATH : "${ncurses.out}/bin"
'';
- meta = with stdenv.lib; {
+ meta = with lib; {
homepage = https://github.com/so-fancy/diff-so-fancy;
description = "Good-looking diffs filter for git";
license = licenses.mit;
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
index 35918ff7..1f1b8284 100644
--- a/tv/5pkgs/simple/fzmenu/default.nix
+++ b/tv/5pkgs/simple/fzmenu/default.nix
@@ -1,4 +1,7 @@
-{ coreutils, dash, gnused, fzf, pass-otp, runCommand, rxvt_unicode, stdenv, utillinux, xdotool }:
+{ lib, stdenv
+, runCommand
+, coreutils, dash, gnused, fzf, pass-otp, rxvt_unicode, utillinux, xdotool
+}:
runCommand "fzmenu" {
} /* sh */ ''
@@ -8,7 +11,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/otpmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf
@@ -21,7 +24,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/passmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf
diff --git a/tv/5pkgs/simple/hc.nix b/tv/5pkgs/simple/hc.nix
index 4d325e16..086445ec 100644
--- a/tv/5pkgs/simple/hc.nix
+++ b/tv/5pkgs/simple/hc.nix
@@ -1,4 +1,6 @@
-{ coreutils, fetchgit, findutils, gawk, gnugrep, makeWrapper, qrencode, stdenv, texlive, utillinux, zbar }:
+{ fetchgit, lib, makeWrapper, stdenv
+, coreutils, findutils, gawk, gnugrep, qrencode, texlive, utillinux, zbar
+}:
stdenv.mkDerivation rec {
name = "hc-${meta.version}";
@@ -19,7 +21,7 @@ stdenv.mkDerivation rec {
cp $src/bin/hc $out/bin/hc
wrapProgram $out/bin/hc \
- --prefix PATH : ${stdenv.lib.makeBinPath [
+ --prefix PATH : ${lib.makeBinPath [
coreutils
findutils
gawk
diff --git a/tv/5pkgs/simple/rox-filer.nix b/tv/5pkgs/simple/rox-filer.nix
index bce89cac..b380bdff 100644
--- a/tv/5pkgs/simple/rox-filer.nix
+++ b/tv/5pkgs/simple/rox-filer.nix
@@ -1,4 +1,5 @@
-{ autoconf, stdenv, fetchFromGitLab, pkgconfig, libxml2, libSM, shared-mime-info
+{ fetchFromGitLab, lib, stdenv
+, autoconf, pkgconfig, libxml2, libSM, shared-mime-info
, libxslt, docbook_xml_dtd_412, docbook_xsl
, gtk ? gtk2, gtk2
}:
@@ -84,7 +85,7 @@ stdenv.mkDerivation {
ln -sv application-{msword,rtf}.png
'';
- meta = with stdenv.lib; {
+ meta = with lib; {
description = "Fast, lightweight, gtk2 file manager";
homepage = "http://rox.sourceforge.net/desktop";
license = with licenses; [ gpl2 lgpl2 ];
diff --git a/tv/5pkgs/simple/utsushi.nix b/tv/5pkgs/simple/utsushi.nix
index 0414eae0..678cdc56 100644
--- a/tv/5pkgs/simple/utsushi.nix
+++ b/tv/5pkgs/simple/utsushi.nix
@@ -1,4 +1,6 @@
-{ boost, fetchurl, file, imagemagick, libudev, libusb, pkgconfig, stdenv
+{ fetchurl, lib, stdenv
+
+, boost, file, imagemagick, libudev, libusb, pkgconfig
, coreutils, dash, patchelf, writeScriptBin # for add-rpath
, guiSupport ? false, gtkmm2 ? null
@@ -81,7 +83,7 @@ let
preFixup = ''
patchelf --set-interpreter \
- ${stdenv.glibc}/lib/ld-linux${stdenv.lib.optionalString stdenv.is64bit "-x86-64"}.so.2 \
+ ${stdenv.glibc}/lib/ld-linux${lib.optionalString stdenv.is64bit "-x86-64"}.so.2 \
$out/lib/utsushi/networkscan
# libstdc++.so.6
@@ -96,9 +98,9 @@ let
Image Scan v3 scanner driver bundle, which can be used by Utsushi.
'';
homepage = "http://support.epson.net/linux/en/imagescanv3.php?version=${version}";
- license = stdenv.lib.licenses.eapl;
- maintainers = [ stdenv.lib.maintainers.tv ];
- platforms = stdenv.lib.platforms.linux;
+ license = lib.licenses.eapl;
+ maintainers = [ lib.maintainers.tv ];
+ platforms = lib.platforms.linux;
};
};
@@ -129,7 +131,7 @@ stdenv.mkDerivation rec {
# Allow configuration to be done via /etc/utsushi.conf
ln -s /etc/utsushi.conf $out/etc/utsushi/utsushi.conf
- ${stdenv.lib.optionalString saneSupport ''
+ ${lib.optionalString saneSupport ''
# Make this package compatible with hardware.sane.extraBackends
mkdir $out/etc/sane.d
echo utsushi > $out/etc/sane.d/dll.conf
@@ -137,7 +139,7 @@ stdenv.mkDerivation rec {
ln -s $out/lib/utsushi/sane/libsane-utsushi.* $out/lib/sane
''}
- ${stdenv.lib.optionalString networkSupport ''
+ ${lib.optionalString networkSupport ''
ln -s ${imagescan-plugin-networkscan}/lib/utsushi/networkscan \
$out/libexec/utsushi/
''}
@@ -151,7 +153,7 @@ stdenv.mkDerivation rec {
#
preFixup = ''
add-rpath ${boost}/lib $out/lib/utsushi/libdrv-esci.so
- ${stdenv.lib.optionalString saneSupport ''
+ ${lib.optionalString saneSupport ''
add-rpath ${boost}/lib $out/lib/utsushi/sane/libsane-utsushi.so
''}
'';
@@ -167,10 +169,10 @@ stdenv.mkDerivation rec {
libudev
libusb
]
- ++ stdenv.lib.optional guiSupport gtkmm2
- ++ stdenv.lib.optional ocrSupport tesseract
- ++ stdenv.lib.optional saneSupport saneBackends
- ++ stdenv.lib.optional tiffSupport libtiff
+ ++ lib.optional guiSupport gtkmm2
+ ++ lib.optional ocrSupport tesseract
+ ++ lib.optional saneSupport saneBackends
+ ++ lib.optional tiffSupport libtiff
;
NIX_CFLAGS_COMPILE = [
@@ -184,16 +186,16 @@ stdenv.mkDerivation rec {
"--with-magick-pp"
"--with-udev-confdir=$(out)/etc/udev"
]
- ++ stdenv.lib.optionals guiSupport [
+ ++ lib.optionals guiSupport [
"--with-gtkmm"
]
- ++ stdenv.lib.optionals jpegSupport [
+ ++ lib.optionals jpegSupport [
"--with-jpeg"
]
- ++ stdenv.lib.optionals saneSupport [
+ ++ lib.optionals saneSupport [
"--with-sane"
]
- ++ stdenv.lib.optionals tiffSupport [
+ ++ lib.optionals tiffSupport [
"--with-tiff"
]
;
@@ -210,8 +212,8 @@ stdenv.mkDerivation rec {
around the SANE standard.
'';
homepage = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX;
- license = stdenv.lib.licenses.gpl3;
- maintainers = [ stdenv.lib.maintainers.tv ];
- platforms = stdenv.lib.platforms.linux;
+ license = lib.licenses.gpl3;
+ maintainers = [ lib.maintainers.tv ];
+ platforms = lib.platforms.linux;
};
}