summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 9942ff65..a45e040e 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -151,7 +151,7 @@ let {
setlocal foldmethod=syntax
'';
"/syntax/todo.vim".text = ''
- syn match Comment /#.*/
+ syn match todoComment /#.*/
syn match todoDate /^[1-9]\S*/
\ nextgroup=todoSummary
@@ -173,6 +173,7 @@ let {
syn sync minlines=1000
+ hi link todoComment Comment
hi todoDate ctermfg=255
hi todoSummary ctermfg=229
hi todoBlock ctermfg=248
@@ -346,6 +347,7 @@ let {
(writerName ''\([^"]*\.\)\?vimrc'')
];
xdefaults = {};
+ xmodmap = {};
}))}
" Clear syntax that interferes with nixINSIDE_DOLLAR_CURLY.
@@ -391,6 +393,9 @@ let {
\ matchgroup=sedSemicolon end=";\|$"
\ contains=sedWhitespace
'';
+ "/syntax/xmodmap.vim".text = ''
+ syn match xmodmapComment /^\s*!.*/
+ '';
}))
];
@@ -485,6 +490,8 @@ let {
inoremap <f1> <esc>:tabp<cr>
inoremap <f2> <esc>:tabn<cr>
+ noremap <f3> :ShowSyntax<cr>
+
" <C-{Up,Down,Right,Left>
noremap <esc>Oa <nop> | noremap! <esc>Oa <nop>
noremap <esc>Ob <nop> | noremap! <esc>Ob <nop>