summaryrefslogtreecommitdiffstats
path: root/tv/2configs/retiolum.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/retiolum.nix')
-rw-r--r--tv/2configs/retiolum.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tv/2configs/retiolum.nix b/tv/2configs/retiolum.nix
index de77de38..1b176e0b 100644
--- a/tv/2configs/retiolum.nix
+++ b/tv/2configs/retiolum.nix
@@ -11,6 +11,16 @@ with import ./lib;
LocalDiscovery = yes
'';
tincPackage = pkgs.tinc_pre;
+ tincUp = lib.mkIf config.systemd.network.enable "";
+ };
+ systemd.network.networks.retiolum = {
+ matchConfig.Name = "retiolum";
+ address = let
+ inherit (config.krebs.build.host.nets.retiolum) ip4 ip6;
+ in [
+ "${ip4.addr}/${toString ip4.prefixLength}"
+ "${ip6.addr}/${toString ip6.prefixLength}"
+ ];
};
tv.iptables.input-internet-accept-tcp = singleton "tinc";
tv.iptables.input-internet-accept-udp = singleton "tinc";