summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/x220.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/hw/x220.nix')
-rw-r--r--tv/2configs/hw/x220.nix22
1 files changed, 20 insertions, 2 deletions
diff --git a/tv/2configs/hw/x220.nix b/tv/2configs/hw/x220.nix
index e0a04e21..38a89cfc 100644
--- a/tv/2configs/hw/x220.nix
+++ b/tv/2configs/hw/x220.nix
@@ -1,10 +1,28 @@
-{ pkgs, ... }:
-
+{ config, pkgs, ... }:
{
imports = [
../smartd.nix
+ {
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.acpi_call
+ ];
+
+ boot.kernelModules = [
+ "acpi_call"
+ ];
+
+ environment.systemPackages = [
+ pkgs.tpacpi-bat
+ ];
+ }
];
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.tp_smapi
+ ];
+
+ boot.kernelModules = [ "tp_smapi" ];
+
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;