summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/AO753.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/hw/AO753.nix')
-rw-r--r--tv/2configs/hw/AO753.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/tv/2configs/hw/AO753.nix b/tv/2configs/hw/AO753.nix
index 469f5c6f..dd6fcfe6 100644
--- a/tv/2configs/hw/AO753.nix
+++ b/tv/2configs/hw/AO753.nix
@@ -5,6 +5,18 @@ with import <stockholm/lib>;
{
imports = [
../smartd.nix
+
+ {
+ nix.buildCores = 2;
+ nix.maxJobs = 2;
+ }
+ (if lib.versionAtLeast (lib.versions.majorMinor lib.version) "21.11" then {
+ nix.daemonCPUSchedPolicy = "batch";
+ nix.daemonIOSchedPriority = 1;
+ } else {
+ nix.daemonIONiceLevel = 1;
+ nix.daemonNiceLevel = 1;
+ })
];
boot.loader.grub = {
@@ -21,21 +33,10 @@ with import <stockholm/lib>;
"wl"
];
- # broadcom_sta is marked as broken for 5.9+
- # pkgs.linuxPackages_latest ist 5.9
- boot.kernelPackages = pkgs.linuxPackages_5_8;
-
boot.extraModulePackages = [
config.boot.kernelPackages.broadcom_sta
];
- nix = {
- buildCores = 2;
- maxJobs = 2;
- daemonIONiceLevel = 1;
- daemonNiceLevel = 1;
- };
-
services.logind.extraConfig = ''
HandleHibernateKey=ignore
HandleLidSwitch=ignore