summaryrefslogtreecommitdiffstats
path: root/tv/2configs/elm-packages-proxy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/elm-packages-proxy.nix')
-rw-r--r--tv/2configs/elm-packages-proxy.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tv/2configs/elm-packages-proxy.nix b/tv/2configs/elm-packages-proxy.nix
index bc471a32..cc1e119c 100644
--- a/tv/2configs/elm-packages-proxy.nix
+++ b/tv/2configs/elm-packages-proxy.nix
@@ -165,7 +165,6 @@ in {
;;
'POST /all-packages/since/'*)
- # TODO only show newest?
my_packages=$(
cd ${cfg.packageDir}
find -mindepth 3 -maxdepth 3 |
@@ -174,7 +173,9 @@ in {
map(
select(.!="") |
sub("^\\./(?<author>[^/]+)/(?<pname>[^/]+)/(?<version>[^/]+)$";"\(.author)/\(.pname)@\(.version)")
- )
+ ) |
+ sort_by(split("@") | [.[0]]+(.[1]|split("."))) |
+ reverse
'
)