summaryrefslogtreecommitdiffstats
path: root/tv/1systems/nomic/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/1systems/nomic/config.nix')
-rw-r--r--tv/1systems/nomic/config.nix74
1 files changed, 74 insertions, 0 deletions
diff --git a/tv/1systems/nomic/config.nix b/tv/1systems/nomic/config.nix
new file mode 100644
index 00000000..d0144986
--- /dev/null
+++ b/tv/1systems/nomic/config.nix
@@ -0,0 +1,74 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+
+{
+ krebs.build.host = config.krebs.hosts.nomic;
+
+ imports = [
+ <stockholm/tv>
+ <stockholm/tv/2configs/hw/x220.nix>
+ <stockholm/tv/2configs/exim-retiolum.nix>
+ <stockholm/tv/2configs/gitrepos.nix>
+ <stockholm/tv/2configs/im.nix>
+ <stockholm/tv/2configs/mail-client.nix>
+ <stockholm/tv/2configs/nginx/public_html.nix>
+ <stockholm/tv/2configs/pulse.nix>
+ <stockholm/tv/2configs/retiolum.nix>
+ <stockholm/tv/2configs/xserver>
+ ];
+
+ boot.initrd.luks = {
+ cryptoModules = [ "aes" "sha512" "xts" ];
+ devices = [
+ { name = "luks1"; device = "/dev/sda2"; }
+ ];
+ };
+
+ # Don't use UEFI because current disk was partitioned/formatted for AO753.
+ # TODO remove following bool.loader section after repartitioning/reformatting
+ boot.loader = {
+ grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+ systemd-boot.enable = mkForce false;
+ };
+
+ fileSystems."/" =
+ { device = "/dev/mapper/nomic1-root";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/sda1";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/mapper/nomic1-home";
+ fsType = "btrfs";
+ };
+
+ swapDevices = [ ];
+
+ # TODO base
+ boot.tmpOnTmpfs = true;
+
+ environment.systemPackages = with pkgs; [
+ (writeDashBin "play" ''
+ set -euf
+ mpv() { exec ${mpv}/bin/mpv "$@"; }
+ case $1 in
+ deepmix) mpv http://deepmix.ru/deepmix128.pls;;
+ groovesalad) mpv http://somafm.com/play/groovesalad;;
+ ntslive) mpv http://listen2.ntslive.co.uk/listen.pls;;
+ *)
+ echo "$0: bad argument: $*" >&2
+ exit 23
+ esac
+ '')
+ gnupg
+ tmux
+ ];
+}