summaryrefslogtreecommitdiffstats
path: root/tv/1systems/caxi/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/1systems/caxi/config.nix')
-rw-r--r--tv/1systems/caxi/config.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tv/1systems/caxi/config.nix b/tv/1systems/caxi/config.nix
new file mode 100644
index 00000000..b136d1ad
--- /dev/null
+++ b/tv/1systems/caxi/config.nix
@@ -0,0 +1,25 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ krebs.build.host = config.krebs.hosts.caxi;
+
+ imports = [
+ <stockholm/tv>
+ <stockholm/tv/2configs/hw/CAC-Developer-1.nix>
+ <stockholm/tv/2configs/fs/CAC-CentOS-7-64bit.nix>
+ <stockholm/tv/2configs/retiolum.nix>
+ ];
+
+ networking = let
+ inherit (config.krebs.build.host.nets.internet) ip4;
+ in {
+ interfaces.enp2s1.ip4 = singleton {
+ address = ip4.addr;
+ prefixLength = fromJSON (head (match ".*/([0-9]+)" ip4.prefix));
+ };
+ defaultGateway = head (match "([^/]*)\.0/[0-9]+" ip4.prefix) + ".1";
+ nameservers = ["8.8.8.8"];
+ };
+}