summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 3695ed3a..00000000
--- a/shell.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-let
- lib = import ./lib;
- pkgs = import <nixpkgs> {
- overlays = [
- (import ./krebs/5pkgs)
- (import ./submodules/nix-writers/pkgs)
- ];
- };
-
-in pkgs.stdenv.mkDerivation {
- name = "stockholm";
- shellHook = /* sh */ ''
- export NIX_PATH=stockholm=${toString ./.}:nixpkgs=${toString <nixpkgs>}
- if test -e /nix/var/nix/daemon-socket/socket; then
- export NIX_REMOTE=daemon
- fi
- export PATH=${lib.makeBinPath [
- pkgs.stockholm
- ]}''${PATH+:$PATH}
-
- eval "$(declare -F | ${pkgs.gnused}/bin/sed s/declare/unset/)"
- shopt -u no_empty_cmd_completion
- unalias -a
-
- enable -n \
- . [ alias bg bind break builtin caller cd command compgen complete \
- compopt continue dirs disown eval exec false fc fg getopts hash \
- help history jobs kill let local logout mapfile popd printf pushd \
- pwd read readarray readonly shift source suspend test times trap \
- true typeset ulimit umask unalias wait
-
- exitHandler() {
- :
- }
-
- PS1='\[\e[38;5;162m\]\w\[\e[0m\] '
- '';
-}