summaryrefslogtreecommitdiffstats
path: root/nin/2configs/weechat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nin/2configs/weechat.nix')
-rw-r--r--nin/2configs/weechat.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nin/2configs/weechat.nix b/nin/2configs/weechat.nix
new file mode 100644
index 00000000..6c0fb313
--- /dev/null
+++ b/nin/2configs/weechat.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import <stockholm/lib>) genid;
+in {
+ krebs.per-user.chat.packages = with pkgs; [
+ mosh
+ weechat
+ tmux
+ ];
+
+ users.extraUsers.chat = {
+ home = "/home/chat";
+ uid = genid "chat";
+ useDefaultShell = true;
+ createHome = true;
+ openssh.authorizedKeys.keys = [
+ config.krebs.users.nin.pubkey
+ ];
+ };
+}