summaryrefslogtreecommitdiffstats
path: root/nin/2configs/im.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nin/2configs/im.nix')
-rw-r--r--nin/2configs/im.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nin/2configs/im.nix b/nin/2configs/im.nix
new file mode 100644
index 00000000..b078dbd5
--- /dev/null
+++ b/nin/2configs/im.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+{
+ environment.systemPackages = with pkgs; [
+ (pkgs.writeDashBin "im" ''
+ export PATH=${makeSearchPath "bin" (with pkgs; [
+ tmux
+ gnugrep
+ weechat
+ ])}
+ ssh chat@onondaga
+ if tmux list-sessions -F\#S | grep -q '^im''$'; then
+ exec tmux attach -t im
+ else
+ exec tmux new -s im weechat
+ fi
+ '')
+ ];
+}