summaryrefslogtreecommitdiffstats
path: root/nin/2configs/ableton.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nin/2configs/ableton.nix')
-rw-r--r--nin/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nin/2configs/ableton.nix b/nin/2configs/ableton.nix
new file mode 100644
index 00000000..343a9089
--- /dev/null
+++ b/nin/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.nin;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}