summaryrefslogtreecommitdiffstats
path: root/mb/1systems/orange/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mb/1systems/orange/hardware-configuration.nix')
-rw-r--r--mb/1systems/orange/hardware-configuration.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/mb/1systems/orange/hardware-configuration.nix b/mb/1systems/orange/hardware-configuration.nix
new file mode 100644
index 00000000..8aa19126
--- /dev/null
+++ b/mb/1systems/orange/hardware-configuration.nix
@@ -0,0 +1,28 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "ohci_pci" "ehci_pci" "pata_atiixp" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/b1d32c54-35f8-4bf1-9fd2-82adc760af01";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/BF9B-03A2";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+}