summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/ratt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/ratt/default.nix')
-rw-r--r--makefu/5pkgs/ratt/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/5pkgs/ratt/default.nix b/makefu/5pkgs/ratt/default.nix
new file mode 100644
index 00000000..57ea545b
--- /dev/null
+++ b/makefu/5pkgs/ratt/default.nix
@@ -0,0 +1,26 @@
+{ buildGoModule, fetchFromSourcehut, lib }:
+buildGoModule rec {
+ pname = "ratt";
+ version = "unstable-2022-05-09";
+
+ src = fetchFromSourcehut {
+ owner = "~ghost08";
+ repo = "ratt";
+ rev = "bf539e1cb04017f5e9d248a8e5f7a6f22f77d06e";
+ sha256 = "0pfz6wnmpwabklayah3bddxkhvg64f5hfyvzkv3xfqpw8c70jdll";
+ };
+
+ proxyVendor = true;
+ vendorSha256 = "sha256-901xkzF/p/kUy7tZELwNhgepRDScUeWQM3isy7APuik=";
+
+ # tests try to access the internet to scrape websites
+ doCheck = false;
+
+ meta = with lib; {
+ description = "A tool for converting websites to rss/atom feeds";
+ homepage = "https://git.sr.ht/~ghost08/ratt";
+ license = licenses.mit;
+ maintainers = with maintainers; [ kmein ];
+ platforms = platforms.linux ++ platforms.darwin;
+ };
+}