summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/kalauerbot/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/kalauerbot/default.nix')
-rw-r--r--makefu/5pkgs/kalauerbot/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/makefu/5pkgs/kalauerbot/default.nix b/makefu/5pkgs/kalauerbot/default.nix
new file mode 100644
index 00000000..2cecbc3f
--- /dev/null
+++ b/makefu/5pkgs/kalauerbot/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, python3, fetchgit }:
+python3.pkgs.buildPythonPackage rec {
+name = "kalauerbot";
+rev = "08d98aa";
+ src = fetchgit {
+ url = "http://cgit.euer.krebsco.de/kalauerbot";
+ inherit rev;
+ sha256 = "017hh61smgq4zsxd10brgwmykwgwabgllxjs31xayvs1hnqmkv2v";
+ };
+ propagatedBuildInputs = with python3.pkgs;[
+ (callPackage ./python-matrixbot.nix {})
+ (stdenv.lib.overrideDerivation googletrans (self: {
+ patches = [ ./translate.patch ];
+ }))
+ ];
+ checkInputs = [ python3.pkgs.black ];
+}
+