summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/kalauerbot/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/kalauerbot/default.nix')
-rw-r--r--makefu/5pkgs/kalauerbot/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/makefu/5pkgs/kalauerbot/default.nix b/makefu/5pkgs/kalauerbot/default.nix
index 2cecbc3f..ee90fdee 100644
--- a/makefu/5pkgs/kalauerbot/default.nix
+++ b/makefu/5pkgs/kalauerbot/default.nix
@@ -8,7 +8,12 @@ rev = "08d98aa";
sha256 = "017hh61smgq4zsxd10brgwmykwgwabgllxjs31xayvs1hnqmkv2v";
};
propagatedBuildInputs = with python3.pkgs;[
- (callPackage ./python-matrixbot.nix {})
+ (callPackage ./python-matrixbot.nix {
+ matrix-client = (stdenv.lib.overrideDerivation matrix-client (self: {
+ patches = [ ./badsync.patch ];
+ }));
+ })
+
(stdenv.lib.overrideDerivation googletrans (self: {
patches = [ ./translate.patch ];
}))