summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/custom/liveproxy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/custom/liveproxy/default.nix')
-rw-r--r--makefu/5pkgs/custom/liveproxy/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/makefu/5pkgs/custom/liveproxy/default.nix b/makefu/5pkgs/custom/liveproxy/default.nix
new file mode 100644
index 00000000..ba5ddee6
--- /dev/null
+++ b/makefu/5pkgs/custom/liveproxy/default.nix
@@ -0,0 +1,30 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, streamlink
+}:
+
+buildPythonPackage rec {
+ pname = "liveproxy";
+ version = "0.3.0";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "70ba2f7b57cdf19c6d971a434ed47cccb5fdfe4621baa76a3f6221e75b7f2729";
+ };
+
+ # # Package conditions to handle
+ # # might have to sed setup.py and egg.info in patchPhase
+ # # sed -i "s/<package>.../<package>/"
+ # streamlink (>=1.1.1)
+ propagatedBuildInputs = [
+ streamlink
+ ];
+
+ meta = with lib; {
+ description = "LiveProxy is a local Proxyserver between Streamlink and an URL";
+ homepage = https://github.com/back-to/liveproxy;
+ license = lib.licenses.bsd2;
+ # maintainers = [ maintainers. ];
+ };
+}