summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/state.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/state.nix')
-rw-r--r--makefu/3modules/state.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/makefu/3modules/state.nix b/makefu/3modules/state.nix
index 461b9015..a87f438f 100644
--- a/makefu/3modules/state.nix
+++ b/makefu/3modules/state.nix
@@ -6,4 +6,11 @@
description = "state which is currently scattered on the machine";
default = [];
};
+
+ config.system.activationScripts.state = lib.optionalString (config.state != []) ''
+ cat << EOF
+ This machine is burdened with state:
+ ${lib.concatMapStringsSep "\n" (d: "* ${d}") config.state}
+ EOF
+ '';
}