summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/opentracker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/opentracker.nix')
-rw-r--r--makefu/2configs/opentracker.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/makefu/2configs/opentracker.nix b/makefu/2configs/opentracker.nix
new file mode 100644
index 00000000..f9810562
--- /dev/null
+++ b/makefu/2configs/opentracker.nix
@@ -0,0 +1,16 @@
+{pkgs, ...}:
+
+let
+ daemon-port = 16969;
+ cfgfile = pkgs.writeText "opentracker-cfg" ''
+ '';
+in {
+ # Opentracker does not support local IPs (10.0.0.0/8 )
+ makefu.opentracker = {
+ enable = true;
+ args = "-p ${toString daemon-port} -P ${toString daemon-port}";
+ };
+ networking.firewall.allowedTCPPorts = [ daemon-port ];
+ networking.firewall.allowedUDPPorts = [ daemon-port ];
+
+}