summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/mqtt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/mqtt.nix')
-rw-r--r--makefu/2configs/mqtt.nix20
1 files changed, 13 insertions, 7 deletions
diff --git a/makefu/2configs/mqtt.nix b/makefu/2configs/mqtt.nix
index 9d1da839..cba43e22 100644
--- a/makefu/2configs/mqtt.nix
+++ b/makefu/2configs/mqtt.nix
@@ -2,12 +2,18 @@
{
services.mosquitto = {
enable = true;
- host = "0.0.0.0";
- users = {};
- # TODO: secure that shit
- aclExtraConf = ''
- pattern readwrite #
- '';
- allowAnonymous = true;
+ persistence = false;
+ settings.max_keepalive = 60;
+ listeners = [
+ {
+ port = 1883;
+ omitPasswordAuth = true;
+ users = {};
+ settings = {
+ allow_anonymous = true;
+ };
+ acl = [ "topic readwrite #" "pattern readwrite #" ];
+ }
+ ];
};
}