summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/jellyfin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/jellyfin.nix')
-rw-r--r--makefu/2configs/home/jellyfin.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/makefu/2configs/home/jellyfin.nix b/makefu/2configs/home/jellyfin.nix
new file mode 100644
index 00000000..672a483e
--- /dev/null
+++ b/makefu/2configs/home/jellyfin.nix
@@ -0,0 +1,10 @@
+{ lib, config, ... }:
+{
+ services.jellyfin.enable = true;
+ services.jellyfin.openFirewall = true;
+ #users.users.${config.services.jellyfin.user}.extraGroups = [ "download" "video" "render" ];
+ state = [ "/var/lib/jellyfin" ];
+ systemd.services.jellyfin.serviceConfig.PrivateDevices = lib.mkForce false;
+ systemd.services.jellyfin.serviceConfig.DeviceAllow = lib.mkForce ["char-drm rwm" "char-nvidia-frontend" "char-nvidia-uvm"];
+ systemd.services.jellyfin.serviceConfig.SupplementaryGroups = [ "video" "render" "download" ];
+}