summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/light/arbeitszimmer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/home/ham/light/arbeitszimmer.nix')
-rw-r--r--makefu/2configs/home/ham/light/arbeitszimmer.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/makefu/2configs/home/ham/light/arbeitszimmer.nix b/makefu/2configs/home/ham/light/arbeitszimmer.nix
index bc60678b..45fbfb57 100644
--- a/makefu/2configs/home/ham/light/arbeitszimmer.nix
+++ b/makefu/2configs/home/ham/light/arbeitszimmer.nix
@@ -6,7 +6,8 @@ let
];
arbeitszimmerbeleuchtung = [
"light.arbeitszimmer_schrank_dimmer"
- "light.arbeitszimmer_kerze" # arbeitszimmer_kerze
+ "light.arbeitszimmer_kerze"
+ "light.arbeitszimmer_pflanzenlicht"
];
in {
services.home-assistant.config.light = [
@@ -20,5 +21,22 @@ in {
name = "Arbeitszimmer Deko";
entities = arbeitszimmer_deko;
}
+ { platform = "switch";
+ name = "Arbeitszimmer Pflanzenlicht";
+ entity_id = "switch.arbeitszimmer_stecker1";
+ }
+ ];
+ services.home-assistant.config.automation = [
+ {
+ alias = "Toggle Arbeitszimmerbeleuchtung via Remote";
+ trigger = {
+ platform = "state";
+ entity_id = "sensor.arbeitszimmer_remote1_action";
+ };
+ action = {
+ service = "light.toggle";
+ data.entity_id = "light.arbeitszimmerbeleuchtung";
+ };
+ }
];
}